Add a hidden series to a chart


#1

I’m attempting to add a series to a chart and I want the initial state of that series to be hidden. But the behavior that I’m seeing is that the series is displaying for a split second and then is hidden appropriately. Is there a way to prevent this ‘flash’ of the series before it is hidden? Here’s psuedo code that shows the call sequence:

-Create chart
-[chart reloadData]
-In SChartDatasource:sChart:seriesAtIndex, create the series and set .hidden property to YES
-[chart redrawChart]

#2

I discovered this behavior is due to the series animation being turned on. The behavior I’m seeing is the animation duration of the series hiding. To prevent this, I’m toggling the animation flag in the same way I toggle the hidden flag.


#3

Hi Srgray,

Thanks for sharing your workaround for everyone else here.

I managed to replicate the behaviour with the animation that you mention. I’ll raise this as an issue and we’ll look into it, but I’m glad that you’ve managed to get an acceptable workaround for the time being.

Thanks,
Jan Akerman