Android Shinobi axis padding


Dear All,

I notice a bug in Android Shinobi. If i set a horizontal linear threshold value at say 200. When i use finger to zoom in (minimize )on the y axis, and release my finger. the Shinobi will auto set the maximum y axis at 200, and i can’t see my threshold value.

This is very annoying. Is there a way to fix thsi bug?




Hello Victor,

Thanks for getting in touch.

We are not aware of any bugs in relation to axis padding - could you please provide some more information as to what exactly you are trying to do? If you could include a code snippet this would also help.

In the meantime my advice would be to double check your range related settings on your y axis, in particular the allowPanningOutOfMaxRange method. For reference please see a link below to the Axis api documents:





Thank you. The function  allowPanningOutOfMaxRange and  allowPanningOutOfDefaultRange is working for me.