Disable panning on one axis causing both axes to not have momentum panning


#1

Version: 2.5.4, Edition: Standard

SChartNumberAxis* yAxis = [[SChartNumberAxis alloc] init];
yAxis.enableMomentumPanning = YES;
yAxis.enableMomentumZooming = YES;
yAxis.enableGestureZooming = NO;
yAxis.enableGesturePanning = NO;

SChartNumberAxis *xAxis = [[SChartNumberAxis alloc] init];
xAxis.enableMomentumPanning = YES;
xAxis.enableMomentumZooming = YES;
xAxis.enableGestureZooming = YES;
xAxis.enableGesturePanning = YES;



Result: yAxis not pannable, which is correct, however, xAxis doesn't longer have momentum panning.
Expected: yAxis is not pannable. xAxis is zoomable and pannable with momentum.

#2

Hi,

We’re takign a look into this one at the moment. It’s not something that’s been reported before - but we should have an update shortly.


#3

Any news regarding this? 

I found that if you pan quickly, with the settings I put above, the next time the chart is being redrawn, it’ll actually pan to where the chart should be if it’s panned with momentum.


#4

HI Herli,

We managed to replicate this issue and we’ve found a fix for it. This fix will be included in our next release (should be in the next couple of days), I’ll have someone update this forum post when it’s out.

Thanks,
Jan


#5

Hi Jan,

Thanks for letting me know.

Cheers,
Herli


#6

Hi Herli,

Our new release is now out (version 2.5.5). Let me know if that fixes your issue.

Thanks,

Dan