Get an error when create titanium module with shinobi chart


#1

Hi everyone, 

I have some problem about shinobi chart. I’m trying to create titanuim module by using Shinobi chart but i got an error when i try to init shinobi chart
on xcode.

ShinobiChart * chartObj = [[ShinobiChart alloc] initWithFrame:CGRectMake(0, 0, 100, 100)];

Here is an error that i got

xcodebuild[39015:390763] [MT] iPhoneSimulator: SimVerifier returned: Error Domain=NSPOSIXErrorDomain Code=53 "Simulator verification failed." UserInfo=0x7fe089f33e10 {NSLocalizedFailureReason=A connection to the simulator verification service could not be established., NSLocalizedRecoverySuggestion=Ensure that Xcode.app is installed on a volume with ownership enabled., NSLocalizedDescription=Simulator verification failed.}

Anyone has an idea how to fix this error . I search on google there is no answer for me.

Thank you an avance.


#2

Hi Automaton,

Can I get you to clarify if this issue only happens when initialising a ShinobiChart object?

If you comment this line out, does your titanium module get created successfully?

Kind regards,
Andrew Polkinghorn


#3

Hi Andrew,

Everything go well when i comment initialising a ShinobiChart object line out

and getting these error when i try to initialising a ShinobiChart object.

Regards,

Automaton


#4

Hi automaton,

We’ve had users report success with titanium in the past - personally I don’t have any experience with this so I would try asking on the titanium forums for more help :slight_smile:


#5

Please let me know ASAP. I really need it.

Thank you.


#6

Hi Rippling,

How progress about these error. Do you have any ideas how to fix it. I really need you chart engine.

Please let me know ASAP. Thank you very much.

Regards,

Automaton


#7
[ERROR] : The following build commands failed:
[ERROR] : Ld build/ShinobiCharts.build/Debug-iphonesimulator/ShinobiCharts.build/Objects-normal/i386/ShinobiCharts normal i386
[ERROR] : Ld build/ShinobiCharts.build/Debug-iphonesimulator/ShinobiCharts.build/Objects-normal/x86_64/ShinobiCharts normal x86_64
[ERROR] : (2 failures)

Here is error when i build with titanium


#8

Hi automaton,

I’m afraid we don’t really have any experience with titanium, and I suspect there’s an issue with it using 3rd party static libraries. The linker error you posted above unfortunately doesn’t show the actual linker errors themselves, it just says that the invokation failed so I’m afraid I can’t really help further without seeing more information.