Getting rid of plot area bottom margin/padding


I have a few charts displaying side by side and they have a bit of padding at the bottom (the top part looks ok).

Here’s an image showing this: , it’s obvious it’s all in the shinobi chart if you look at the axis titles on the side. Interestingly, the padding amounts are different even though I’m using the same code to display the charts.

Is there a setting to make the charts expand all the way to the bottom?



Hi radu,

How have you hidden the x-axis on the 3 charts to the right? The recommended way would be to use the SChartAxisStyle;

axisStyle.majorTickStyle.showTicks = NO;
axisStyle.majorTickStyle.showLabels = NO;
axisStyle.minorTickStyle.showTicks = NO;


Sorry, I didn’t specify I was using android (though the screenshot makes it kinda obvious).

I’m using this for all charts (minor ticks shown is false by default so no need to do that):

TickStyle xTickStyle = xAxis.getStyle().getTickStyle();


I also tried adding these but still having the same problem:



Hi Radu,

Have you tried setting the line width of the axis itself to 0 eg. xAxis.getStyle().setLineWidth(0.0f); (and calling chart.redrawChart() if appropriate). By default the axis line is transparent but has a width.

Kind regards,



Thanks Patrick, setting the line wifth on the axis style works perfectly!