How are the widths of columns set?


#1

I’m having a bit of trouble working out how to make my column widths be reasonable:

How do these get set?


#2

I think they are automatically scaled based on the number of values on the axis and the width of the axis.  I have the opposite problem - mine are too fat since I only have 12 values on my axis.  I can’t find any property to change the width.  I’d like to reduce mine to 50% of the current width.


#3

Whatever the scaling is doing here, it’s wrong. Those lines aren’t visible on a retina display. Shinobi guys, any advice?


#4

Hi folks - I hope I can clarify this for you:

We calculate a width in data terms for the bars or columns in a series by examining the minimum distance between any two datapoints along the Y or X axis, respectively. We also take the number of series of bar/column series, and any stacking, into account and add a little spacing by default.

You can configure the amount of spacing between bars/columns and sets of bars/columns (those which are ‘on the same datapoint’) by setting the interSeriesPadding and interSeriesSetPadding properties on the axis’ style object, where 0.f is no padding and 1.f is all padding.

@tonyarnold as you’ve discovered, where the calculated width is very small and the axis range very large, you can run into issues with thin or invisible bars/columns. I’ve sent you an email in the last few minutes which I hope will help in your case.

@giebler wider-than-desired bars/columns are more easily fixed - increasing the padding values should allow you to tweak their widths.

Hope this helps!

Simon  :grin:


#5

Hi All,

my columns are very thin as well. I have 6 data points a month and a number between -2 to 2.

The columns are too thin iwould like to make them wider in order for the chart to look nice.

Can you please help?


#6

@Simon I’m also having difficulty with wider-than-desired columns. The only padding property I see in the documentation is SChartAxis.rangePaddingHigh (and Low). Is this what you were referring to? If so, it won’t solve my issue because I’m setting the range manually and I don’t want to shrink the horizontal area that the columns take up, just decrease their width.

I’ve setup my chart to always have a range of 6 months with one column/datapoint per month. So I don’t need the dynamic column width, though I understand why Shinobi is set up that way. Do you see any way to decrease the column width without decreasing the width of their 6-month range?


#7

Hi - we have the column width API changes planned in our backlog, however I’m not sure when we will be able to begin work on this part of the API, as we’re currently finishing off some changes to the graphics code and other tidy ups. One approach to work around this is to filter your data, and for any columns that are very close together, discard one, so the chart won’t have a small minimum-width-between-adjacent-columns.

Hope this helps :slight_smile: