How to disable loading indicator when using loadDataInBackground


I am using the asynchoronous data load using loadDataInBackground = YES. However, I do not want the loading indicator. i have 5 charts in my view and i do not want a loading indicator for each of the chart. I have my own indicator for my view controller itself.

Is there way to turn off the loading indicator for each of the charts?

How to disable loading indicator?
In example: We always create a loading indicator in method: sChartWillStartLoadingData.You can remove code which you're creating a loading indicator or set clearColor for it.


Hi kenta,

May be I was not clear with my question. When I said i have my own indicator, it is a general purpose indicator for the entire view controller in which i have 5 shinobi charts. My question was, 

When you use asynchronous data loading (by setting chart.loadDataInBackground = YES) for charts, Shinobi chart itself provides a loading indicator each of the charts. So, what happens is, i have 5 loading spinners (including my own) on the view controllers.

I was able to turn off the spinners by using the following.

chart.loadingIndicator = nil;

However, there is a background strip on which this indicator is shown. Now, when loading charts, i dont have an indicator, but just the background view. How do i get rid of the background view as well?


Hello Veerun,

Having tried to replicate your issue I could not find the background strip you refer to still appearing. I would recommend you try setting loadingIndicator.hidden to true as this appears to have the same effect as what you’re after.

Let me know if this works for you.

Kind regards,