iOS 9 support: ShinobiGrid is crashing on dealloc [ShinobiGrid dealloc] // using iOS 9 beta 5, XCode v. 7.0 beta 5 (7A176x)



We are assessing our apps readiness for iOS 9 and are experiencing a few issues with the current library ShinobiGrids - Version: 2.8.0-6, Edition: Standard, Release Date:Mar 16 2015.  We are using ios9 beta 5, XCode v. 7.0 beta 5 (7A176x) to reproduce this issues.

  1. ShinobiGrid is crashing internally on dealloc [ShinobiGrid dealloc] with debugger message “Cannot form weak reference to instance […] of class ShinobiGrid. It is possible that this object was over-released, or is in the process of deallocation.”.  Steps to reproduce are straightforward- create a view containing ShinobiGrid and dealloc it in any way.
  2. Scrolling indicators size is covering whole height of a grid.
  3. No way to set shinobi licence key using trial library - crashes with "couldn’t copy key” message.  jFYI, this is not impacting us as we have a license - just letting you know.

I believe that the Shinobi team are working towards releasing an update for iOS 9 support, but it would be very useful to know if others are seeing these issues and that they will be fixed in the first update for iOS 9 from Shinobi.  Point (1) above is a major problem for us.

Thanks in advance for any help.




Hi sim2015,

Thanks for raising these issues with us! I’ve sent you a direct email about some of the above, but I’ll summarise here also for the benefit of other forumn users.

  1. I’m unable to recreate this issue. I’ve sent you a project where I tried to reproduce the crash but was unable to - this was tested with ShinobiGrids version 2.8.1-2. It would be great if you could alter this project so that it reproduces the problem and then send this back to me so I can start debugging it.
  2. We weren’t aware of this problem. I’ve added this to our backlog to probably be fixed as part of our iOS9 releases.
  3. We’re currently working on a fix for this issue and we’ll be in touch once we know what the problem is.

Hope all that helps! Let us know if you have further comments! :slight_smile:




Thanks v much for your reply Ryan.

To keep the forum up to date, we have returned an adjusted version of your sample project that shows the crash.  The two tweaks made to the project to induce the crash were:

Use of ShinobiDataGrid instead of ShinobiGrid

Setting datasource on self

Thanks again for taking time to look at this.

Cheers and all the best,




Thanks to your adjusted version of the sample we were able to recreate issue 1. We’ve got a local fix for this so we’re hoping to include this in our iOS9 release. We’re still investigating issues 2 and 3 but will be in touch when we have more info.




Great news - thanks Ryan.  We are looking forward to trying the iOS 9 release of Shinobi!




I’ll post my question here, since is tightly related one.

When building with Xcode7 and iOS9, we got the same error. So we checked your updates, and added new libraries to our project (version 2.8.2-2 of ShinobiGrid). Unfortunately, same thing happens. Are you aware of such problem in this version? Any suggestions?


Hi markokoleznik,

We tried and tested an alpha build of the fix that Ryan did which worked well.  In the next day or so we will take the full release and give that a whirl and let you know if we see any differences in behaviour.

Perhaps you can post a code snippet here to demonstrate how the crash you are seeing occurs?



@sim2015 I’m trully sorry, I haven’t noticed that Xcode grabbed older version of ShinobiGrids. Once I’ve read CHANGELOG, I was able to use new version of your library and everything worked fine! Sorry for misleading information  smiley red


Good morning markokoleznik,
No worries, glad it is all working well for you.
Thanks again to Ryan for the original fix.


Glad it’s all working well for everyone :slight_smile: