[iOS9] Licensing problem, couldn't copy key



I tried to integrate ShinobiCarts to a swift project. I followed the steps found in this tutorial: file:///Users/balazsgollner/Desktop/shinobicharts/Documentation/quickstart-Swift.html
The app compiles just fine, but when I try to display the VC with the chart, the app crashes, and in the debug console the following line appears:

"couldn't copy key"

The stack trace is the following at this point:

* thread #1: tid = 0x46cee, 0x00000001132c9286 libsystem_kernel.dylib`__pthread_kill + 10, queue = 'com.apple.main-thread', stop reason = signal SIGABRT

    frame #0: 0x00000001132c9286 libsystem_kernel.dylib`__pthread_kill + 10

    frame #1: 0x00000001132929f9 libsystem_pthread.dylib`pthread_kill + 90

    frame #2: 0x0000000113029a44 libsystem_c.dylib`abort + 129

    frame #3: 0x000000010f5c36c4 aperturegroup`KeyAssert + 420

    frame #4: 0x000000010f5c34ad aperturegroup`+[SChart_License setPublicKey:tag:] + 2093

    frame #5: 0x000000010f5c3b14 aperturegroup`+[SChart_License decryptAndCheckSignature:licenseInfo64:] + 388

    frame #6: 0x000000010f5c436a aperturegroup`+[SChart_License verifyKey:nilKeyMessage:] + 186

    frame #7: 0x000000010f5c4262 aperturegroup`+[SChart_License verifyKey:] + 50

    frame #8: 0x000000010f531674 aperturegroup`-[SChartCanvas drawChart:] + 292

    frame #9: 0x000000010f52d3ec aperturegroup`-[SChartCanvasRenderView drawRect:] + 92

    frame #10: 0x0000000110592499 UIKit`-[UIView(CALayerDelegate) drawLayer:inContext:] + 495

    frame #11: 0x00000001101c1f53 QuartzCore`-[CALayer drawInContext:] + 257

    frame #12: 0x00000001101c18ca QuartzCore`CA::Layer::display_() + 558

    frame #13: 0x00000001101b69c9 QuartzCore`CA::Layer::display_if_needed(CA::Transaction*) + 293

    frame #14: 0x00000001101b6a59 QuartzCore`CA::Layer::layout_and_display_if_needed(CA::Transaction*) + 35

    frame #15: 0x00000001101ab1d5 QuartzCore`CA::Context::commit_transaction(CA::Transaction*) + 277

    frame #16: 0x00000001101d89f0 QuartzCore`CA::Transaction::commit() + 508

    frame #17: 0x00000001104e0556 UIKit`_UIApplicationHandleEventQueue + 7183

    frame #18: 0x0000000112218b21 CoreFoundation` __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17

    frame #19: 0x000000011220ea4c CoreFoundation`__CFRunLoopDoSources0 + 556

    frame #20: 0x000000011220df03 CoreFoundation`__CFRunLoopRun + 867

    frame #21: 0x000000011220d918 CoreFoundation`CFRunLoopRunSpecific + 488

    frame #22: 0x00000001151f4ad2 GraphicsServices`GSEventRunModal + 161

    frame #23: 0x00000001104e599e UIKit`UIApplicationMain + 171

  * frame #24: 0x000000010f38ab7d aperturegroup`main + 109 at AppDelegate.swift:12

    frame #25: 0x0000000112f7d92d libdyld.dylib`start + 1

    frame #26: 0x0000000112f7d92d libdyld.dylib`start + 1

I used Xcode 7 beta 5 with iOS 9 simulator. Charting framework version is 2.8.1-3

Please advise


Update: It works on iOS 8.4 both on phone and simulator


I am getting this same thing ([10190:3092646] couldn’t copy key) when I try to run the application on iOS 9 it works fine on iOS 8.4.  Is there something that I can do to work around this issue in the mean time?

import UIKit
 class AnalyzeShinobiCollectionReusableView: UICollectionReusableView, SChartDatasource {
    @IBOutlet weak var lineChart: ShinobiChart!
    override func awakeFromNib() {
        let appDelegate = UIApplication.sharedApplication().delegate as! AppDelegate
        lineChart.licenseKey = appDelegate.shinobiChartsLicenseKey()
         lineChart.datasource = self
     /* SChartDatasource methods */
    func numberOfSeriesInSChart(chart: ShinobiChart!) -> Int {
        return 1
    func sChart(chart: ShinobiChart!, seriesAtIndex index: Int) -> SChartSeries! {
    func sChart(chart: ShinobiChart!, numberOfDataPointsForSeriesAtIndex seriesIndex: Int) -> Int {
        return 100
    func sChart(chart: ShinobiChart!, dataPointAtIndex dataIndex: Int, forSeriesAtIndex seriesIndex: Int) -> SChartData! {
        let dp = SChartDataPoint()
        dp.xValue = dataIndex
        dp.yValue = dataIndex * dataIndex
        return dp


I expierience the Same problem- Any help would Be appreciated!



This is a known issue we have with our trial key checking code in iOS9 (only in our trial versions of our frameworks). We have a local fix for this and are currently working on getting this integrated with all our products.

This fix entails two steps:

  • An update to our web service that generates the trial keys
  • An update to our frameworks that decode the trial keys

This means that once this fix goes live you will need:

  • A new trial key.
  • A new trial framework.

You can get these by signing up for a new trial download here and clicking “Free Trial”. This should immediately trigger the download of a new framework and send a new trial key to you via email.

It is then very important to make sure you replace your old framework with the new one and assign your new license key where you use our component in your project. Xcode sometimes caches project dependencies, so it’s also probably a good idea to do a full project clean.

Please accept our apologies for any inconvenience this is causing you. We’ll be sure to post here once the new trial frameworks/keys are available.




I just downloaded a new framework and key and compiled it, but I get the same problem. iOS9, xcode 7, ShinobiCharts 2.8.1.

Can you help?

Many thanks


Any news on a solution for the trial version running on IOS9?

Same here replace with a new framework and license and same error " couldn’t copy key"



Hi All,

Apologies for the delay in releasing our updated trial versions for iOS9.

We’ve been working hard on getting our iOS9 compatible versions of our products to customers which has unfortunately meant our trials have not yet been updated. However, it’s likely that these will be available if not by the end of this week then early next week. I’ll make a note to update this forum post when the iOS9 compatible trials are made available.

Many thanks for your patience,



Hi All 

i still facing issue on Xcode 7.0 and ios9  " couldn’t copy key"

1. When will be fixed for trail version ? 

2. Is purchased version work correcty with   Xcode 7.0 and ios9   ? 

Can any one help ? 


Hi - any updates on the issue? I really want to commit to purchasing ShinobiCharts and get on with dev, but I’m reluctant to do so while this issue is outstanding. 




We’ve just updated our trial frameworks to the new iOS9 compatible versions of our products. You should now be able to download a new trial that fixes this issue.

Please see my above post for further information.