OpenGL crash in ShinobiCharts for iOS


#1

I have a crash happening within ShinobiCharts on iOS. We have the latest framework and are not using openGL outside ourselves, (no cocos2d, …)  I’m not exactly sure when this is happening, since it’s being recorded in testflight and not by myself. I can say that I have been able to background the app with ShinobiCharts running and it backgrounded fine.

 Any suggestions are appreciated. Thanks.

| 0 | hanna | 0x00051838 | testflight_backtrace |
| 1 | hanna | 0x00051074 | TFSignalHandler |
| 2 | libsystem_platform.dylib | 0x3a707062 | _sigtramp |
| 3 | libGPUSupportMercury.dylib | 0x341d8390 | gpusSubmitDataBuffers |
| 4 | IMGSGX543GLDriver | 0x2e6e182c | SubmitPackets |
| 5 | GLEngine | 0x31b43c3c | gliPresentViewES |
| 6 | OpenGLES | 0x31b4e138 | -[EAGLContext presentRenderbuffer:] |
| 7 | hanna | 0x00093ed2 | -[SChartGLView endRender] |
| 8 | hanna | 0x0009753a | -[SChartCanvas drawChart:] |
| 9 | hanna | 0x000947e4 | -[SChartCanvasRenderView drawRect:] |
| 10 | UIKit | 0x32140640 | -[UIView(CALayerDelegate) drawLayer:inContext:] |
| 11 | QuartzCore | 0x31d76bb8 | -[CALayer drawInContext:] |
| 12 | QuartzCore | 0x31d5f70c | _ZN2CA5Layer8display_Ev |
| 13 | QuartzCore | 0x31d4367c | _ZN2CA5Layer17display_if_neededEPNS_11TransactionE |
| 14 | QuartzCore | 0x31d43314 | _ZN2CA5Layer28layout_and_display_if_neededEPNS_11TransactionE |
| 15 | QuartzCore | 0x31d42d1e | _ZN2CA7Context18commit_transactionEPNS_11TransactionE |
| 16 | QuartzCore | 0x31d42b2e | _ZN2CA11Transaction6commitEv |
| 17 | QuartzCore | 0x31d3c85c | _ZN2CA11Transaction17observer_callbackEP19__CFRunLoopObservermPv |
| 18 | CoreFoundation | 0x2f9191cc | __CFRUNLOOP_IS_CALLING_OUT_TO_AN_OBSERVER_CALLBACK_FUNCTION__ |
| 19 | CoreFoundation | 0x2f916b70 | __CFRunLoopDoObservers |
| 20 | CoreFoundation | 0x2f916eb2 | __CFRunLoopRun |
| 21 | CoreFoundation | 0x2f881c26 | CFRunLoopRunSpecific |
| 22 | CoreFoundation | 0x2f881a0a | CFRunLoopRunInMode |
| 23 | GraphicsServices | 0x34575282 | GSEventRunModal |
| 24 | UIKit | 0x32125048 | UIApplicationMain |
| 25 | hanna | 0x0001511a | main in main.m on Line 23 |
| 26 | libdyld.dylib | 0x3a5ecab6 | start |


#2

It was a backgrounding issue and is resolved.  :grin: