ShinobiCharts 1.7.2 (Android) apps hang when running under ADB (debugger)


What I’m using:

  1. Mac OS X 10.10.1
  2. Android Studio
  3. ShinobiChart 1.7.2 (trial)

The sample apps run fine standalone (without ADB) but hangs when the debugger is attached, showing “Application ShinobiQuickStart (process…) is waiting for the debugger to attach.”

I have no problems debugging other apps on the same Mac and phone.

Many thanks in advance.

AndroidManifest.xml and build.gradle (for shinobichartsandroidlibrary) follow:

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android=""
    package="" >


            android:label="@string/app_name" >
                <action android:name="android.intent.action.MAIN" />
                <category android:name="android.intent.category.LAUNCHER" />

buildscript {
    repositories {
    dependencies {
        classpath ''
        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files

allprojects {
    repositories {


Hi yth,

Hopefully this has been resolved now (we spoke over email). For the benefit of anyone else reading this, this issue wasn’t something we could reproduce ourselves (the debugger seemed to be working fine for all our sample apps when we tried it). It looks like it possibly had something to do with the package name in the manifest which looks like it has been changed from its original value in our sample code.



Hi, Patrick,

This was caused by android:debuggable=“false” in the AndroidManifest.xml file belonging to shinobichartsandroidlibrary.

You can reproduce this by creating a new Android Studio project and importing Shinobi Charts. Look for the directive in question in the AndroidManifest.xml file in both shinobichartsandroidlibrary and the project you’ve just created.


Hi yth,

Thank you for your response and we are glad that you have managed to resolve your problem. We must admit, we tried creating a new Android Studio project and importing ShinobiCharts, but did not observe this setting being automatically applied to the manifest. That said, Android Studio is ever evolving, and as such its quite plausible that its behaviour may vary between versions. 
This post should hopefully help anyone else who may be experiencing any similar issues. 

If you encounter any more problems please let us know, and thanks again for posting your findings.

Kind regards,