ShinobiCharts Android EGL_emulation bad attribute error


Hi! I’m using a paid version of ShinobiChart’s Android v1.9.4-0 (via .aar module) and have run through the Quick Start guide. I’m able to render the chart but in my log I get the following error:

E/EGL_emulation: tid 21660: eglChooseConfig(866): error 0x3004 (EGL_BAD_ATTRIBUTE)

It seems as soon as I update my fragment to have the Shinobi ChartFragment class in my activity’s XML (before even adding data to the chart or styling it). The chart renders fine and doesn’t crash the app but it would be great if you could suggest how to get rid of this error.

Thanks in advance!


Hello eo-jcraddock,
Can you please advise what device you are running the quick start app on? Is it an emulated or physical device? What version of Android is said device running? Have you modified the quick start code in any way? Have you tried any of the sample apps which are included in the download bundle?


Hi Kai!

Thanks for the response. I’m testing this on the emulator’s Pixel devices (both standard and XL). Both are running Android 8.1.0 API 27 but both are producing the same error.

I initially just followed the QuickStart guide to add ShinobiCharts into my own project which had 2 activities and displayed the chart fragment on the 2nd activity. I just ran the Quick Start from the Samples to just confirm that it’s not an issue with my own project. The sample quick start was still producing the same error with a few additional errors below:

04-02 20:24:06.227 1427-1427/? E/adbd: failed to connect to socket ‘localabstract:com.shinobicontrols.charts.sample.shinobiquickstart’: Connection refused
04-02 20:24:12.741 1626-1648/system_process E/BatteryExternalStatsWorker: modem info is invalid: ModemActivityInfo{ mTimestamp=0 mSleepTimeMs=0 mIdleTimeMs=0 mTxTimeMs[]=[0, 0, 0, 0, 0] mRxTimeMs=0 mEnergyUsed=0}
04-02 20:24:19.413 1412-1424/? E/SurfaceFlinger: ro.sf.lcd_density must be defined as a build property
04-02 20:24:19.509 1412-1424/? E/SurfaceFlinger: ro.sf.lcd_density must be defined as a build property
04-02 20:24:19.634 25782-25808/com.shinobicontrols.charts.sample.shinobiquickstart E/EGL_emulation: tid 25808: eglChooseConfig(866): error 0x3004 (EGL_BAD_ATTRIBUTE)
04-02 20:24:19.877 1626-1744/system_process E/TaskPersister: File error accessing recents directory (directory doesn’t exist?).
04-02 20:24:32.730 1626-1644/system_process E/memtrack: Couldn’t load memtrack module

I haven’t edited the sample code in any way besides including the library through the gradle files like the Quick Start instructions say to do. I also had to edit the gradle file to include v4 support because it was throwing an error about not being able to find the byte code for the android/support/v4/app/Fragment. It doesn’t seem like the gradle edits should cause that EGL error though.



Hello Jess,
Thanks for providing the extra information. Can I please ask, do you encounter this error message when testing on a physical device?


Hi Kai,

It doesn’t appear to be happening on the physical device. I ran it on the Pixel 2 XL and BLU Grand M2 physical devices and it doesn’t appear to throw the error message. Perhaps it’s just a simulator issue.



Hi Jess,
Thanks for letting us know. As shinobicharts makes use of openGL I did suspect the emulator. My understanding is that the openGL rendering on emulators can be a little unreliable. We’ve no other outstanding reports of your error but if you do start to spot it cropping up when using physical devices please do let us know.