ShinobiCharts Samples not Working


#1

Hi All,

   I’m trying to evaluate Shinobi Charts, which I downloaded yesterday. When I open a sample project (e.g. LineChart, or any other), and try to run it on the simulator, the xcode compiler gives me the following error:

           Lexical or Preprocessor issue

           'ShinobiCharts/ShinobiChart.h' file not found.

   This error happens on the ViewController.h file.

   Can anyone help me? I’m using xcode 4.6.

   Thanks in advance.

    Aderval


#2

Hi Amsyst,

Sorry you are having this issue. The chart demos are designed to run straight off. However sometimes we find that xcode drops the framework.

Have you checked that the Shinobi framework has been added to the project? If it has not then you will need to add it to resolve the error. If it has been added to the project then it might be a good idea to clean and build you project after having readded the Shinobi framework to your project.

Kind Regards,
Daniel Allsop


#3

Sorry, Dan – frameworks don’t just magically fall out of projects.  The problem is a bug in Shinobi’s getting started documentation.  I’m guessing (wild speculation) that Shinobi engineers have some sort of default setup in their environment that makes things work for them, but not for the rest of the world, as we don’t have those defaults.

Here’s my experience (and, I hope, the answer to Aderval’s question)

* Sign up for Shinobi trial

* Download package, read Getting Started.

* Add ShinobiChart framework, etc., to my project, as directed.

* Add “#import <ShinobiChart/Shinobichart.h>” to code, per instructions.

* Build -> Get error exactly as Aderval describes, above.

* Go to build settings for project -> Edit User Header Search Paths -> Add path -> add “3rdparty/shinobi/ShinobiCharts/ShinobiCharts.embeddedframework/ShinobiCharts.framework” (use your own path to the framework) -> Make it recursive.

* Change import to #import “Shinobi.h”

* Build

* All works fine.

Cheers!


#4

Hi Chum,

Thanks for letting us know your solution. I’ve been trying to reproduce this problem for a while now, and I can’t seem to do it. Could you tell me which version of our charts you are using? We don’t have any special settings in our environment that aren’t included in our projects, so I am having difficulty reproducing the behaviour you are seeing - even when I sign up and download a trial from our website myself. 

Regards,
Chris


#5

don’t do this step:

Go to build settings for project -> Edit User Header Search Paths -> Add path -> add “3rdparty/shinobi/ShinobiCharts/ShinobiCharts.embeddedframework/ShinobiCharts.framework” (use your own path to the framework) -> Make it recursive.

Instead open a sample shinobi project and drag and drop the frameworks/associated files from the sample into your project. Make sure to click copy into and add to all targets when prompted.


#6
Chum
Sorry, Dan -- frameworks don't just magically fall out of projects.  The problem is a bug in Shinobi's getting started documentation.  I'm guessing (wild speculation) that Shinobi engineers have some sort of default setup in their environment that makes
 things work for them, but not for the rest of the world, as we don't have those defaults.
 
Here's my experience (and, I hope, the answer to Aderval's question)
* Sign up for Shinobi trial
* Download package, read Getting Started.
* Add ShinobiChart framework, etc., to my project, as directed.
* Add "#import <ShinobiChart/Shinobichart.h>" to code, per instructions.
* Build -> Get error exactly as Aderval describes, above.
* Go to build settings for project -> Edit User Header Search Paths -> Add path -> add "3rdparty/shinobi/ShinobiCharts/ShinobiCharts.embeddedframework/ShinobiCharts.framework"
 (use your own path to the framework) -> Make it recursive.
* Change import to #import "Shinobi.h"
* Build
* All works fine.
 
Cheers!

Thanks, Chun!!! I have managed to make it work with your solution. Unfortunately I could not wait for it, and I am using another framework right now.

Regards,

Aderval


#7

I’ve tried to do the same. I created a new project, added framework from examples and I get the same error. How can I manage it? I really need to get started. If needed I can upload my project somewhere. Thank you in advance.

 'ShinobiCharts/ShinobiChart.h' file not found.

#8

The docs on the latest download tell you to install the framework so it appears in the framework list in Xcode - but I didn’t do that, I just included it in my project explicitly. The demo projects probably assume it’s already there in Xcode so just name it, instead of explicitly including it.


#9

Are you telling me that you just do “Add files to…” and it worked? I tried also this ways and the result is the same. I do not understand your actions. Could you kindly give me more details?


#10

Hi trapo,

Jay is right, the latest version of Shinobi uses an installer. This will add the framework to Xcode so that you can add ShinobiCharts to your project just like any other framework. Did you use the installer? If you did, the samples should work for you without any modification required.

If you are adding the charts to your own project, here is an excerpt from the Quick Start guide that might help:

Within your newly created project add a reference to the ShinobiCharts framework. If you’ve installed ShinobiCharts using our installer, you can add this in the same way as you would any of the standard Apple frameworks. Select your project target, and switch to the Build Phases tab. Open the Link Binary With Libraries section, click the Plus button, find the entry for  ShinobiCharts.framework , and click Add.

If you have just copied the framework onto your machine, the easiest way to add it to your project is to locate the  ShinobiCharts.framework and drag it directly into your project.

Colin E.


#11

Hi, thank you for the reply. I did not use the installer IIRC, but I directly dragged the framework into my project. I will try with the installer and let you know.


#12

New user here.

Used the installer. Started working with ShinobiGrid. Then I went to use "SGridColRowStyle"

Nothing I could do would allow xcode to see it. Couldn’t do an import, nothing. Then I came across this post.

I modified my Header Search Paths:

/Applications/Xcode.app/Contents/Developer/Library/Frameworks/ShinobiGrids.framework   (recursive)

And now it can find the headers. Weird, and it doesn’t quite feel right. But at least I can continue working.


#13

Also having hyaving this problem post Xcode 5.1 upgrade


#14

I am a new user and double clicked the installer, then opened XCode. The framework “ShinobiEssentials” is not in the “add frameworks” dialog as expected. Grid and charts are there after I installed those. I reopened xcode and cleaned and still nothing.


#15

I added the framework manually and now continue to get this error 

"No ShinobiControls license key given - please set the license key. e.g. in AppDelegate.m #import <ShinobiEssentials/ShinobiEssentials.h> and add the following code [ShinobiEssentials setLicenseKey:@"<your trial license key>"];"

Ive done this and it still is not working. I have my license key in there as instructed.


#16

Hi Johnnytrops,

Have you double checked that you’re adding the correct license key? It should be a very long key, (~700 characters), ending in the ‘+’ character. Are you definitely assigning your trial key before you attempt to create your first component? 

Thanks,
Jan


#17

I am a new user. I tried adding the frame work to a new project I created, and copied the same code for getting started app. But I got the same problem. shinobichart,h not found . Please help me, i need to plot data using this library for my university project