Tick marks problem


#1

Hi, a have a porblem, I’m trying to show ticks marks in a shinobi chart with columns series. The chart have xAxys type date and yAxis type number.

Code

Any idea why I can’t set this.

Thanks for your help.


#2

Hi,

The image you supplied doesn’t seem to be working.

If you could send us the following items this would really help us identify the source of your issue: 

  1. Your current tick mark implementation.
  2. An image of what you want your chart to look like.

Kind regards,
Andrew Polkinghorn


#3
Thanks for your response and Im sorry for the image. I have 2 axis //Axix SChartDateTimeAxis *xAxis = [[SChartDateTimeAxisalloc] init]; And one second with an option to show porcentage or numbers datapoints if (opcionValorBarras == 1) { SChartNumberAxis *yAxis = [[SChartNumberAxisalloc] init]; yAxis.title = @""; yAxis.style.gridStripeStyle.showGridStripes = NO; yAxis.style.majorTickStyle.showTicks = YES; _chart.yAxis = yAxis; _chart.yAxis.rangePaddingHigh = @(cantidadMaximaHab - _valorMaxCantidades + 2); }else{ SChartPercentageAxis *yAxis = [SChartPercentageAxisnew]; yAxis.title = @""; yAxis.style.gridStripeStyle.showGridStripes = NO; yAxis.style.majorTickStyle.showTicks = YES; _chart.yAxis = yAxis; _chart.yAxis.rangePaddingHigh = @(100 - _valorMaxCantidades + 5); }

But at moment to set 

_chart.yAxis.style.majorTickStyle.showTicks = YES; _chart.xAxis.style.majorTickStyle.showTicks = YES; this not works, the ticks marks is not show. The option is ignored. https://db.tt/RnvvzubH code

#4

Hi, 

You need to set the following properties to see a tick mark:

  • showTicks
  • lineLength
  • lineWidth
  • lineColor

These are all properties on the majorTickStyle and the reason the “showTicks” property doesn’t show anything straight away is that the default style used sets the properties above to values like clearColor and zero.

Let me know if you have any questions.

Kind regards,
Andrew Polkinghorn