Time axis cut off


#1

i have a graph that can 2 series (ph and temp) or one or the other. When I view both , the temp axis looks fine.

https://dl.dropboxusercontent.com/u/45836281/image1.png

however when you view the ph axis only, the last label on the time is cut off

https://dl.dropboxusercontent.com/u/45836281/image2.png

and when displaying temp only, the time number as well as the label is cut off.

https://dl.dropboxusercontent.com/u/45836281/image3.png

is there a way to pad the label(s) in the 2nd and 3rd cases such that the stuff in the red boxes looks not as cut off?


#2

Hello Foobar,

Thanks for getting in touch.

Firstly, I am making the assumption here that you are using ShinobiCharts for Android and not it’s iOS stable mate?

If this is the case I believe your issue is because when you hide the respective axis (ph or temp) you are allowing that space (which was taken up by the axis) to now be used as chart plot area. Subsequently, you are actually in fact getting more space to display (in your example) the time labels on the x axis. The chopping off of the time label is occurrinng as there is literally no more space left to the show the label, and thus part of it is ‘off the screen’ and thus omitted. I believe you have two options:

  1. Experiment with the clipping options of the tick mark labels to see if you can improve things. For example you will be able to make the entire label dissappear once it begins to go off the screen, rather than be half shown. The apis to help you with this are below:

http://www.shinobicontrols.com/docs/ShinobiControls/ShinobiChartsAndroid/1.5.0/Premium/Normal/apidocs/docs/reference/com/shinobicontrols/charts/Axis.html#setTickMarkClippingModeLow(com.shinobicontrols.charts.TickMark.ClippingMode)

http://www.shinobicontrols.com/docs/ShinobiControls/ShinobiChartsAndroid/1.5.0/Premium/Normal/apidocs/docs/reference/com/shinobicontrols/charts/Axis.html#setTickMarkClippingModeHigh(com.shinobicontrols.charts.TickMark.ClippingMode)

  1. Add a ‘dummy’ axis to temporarily replace the axis you hide to ‘give back’ the space in order for the labels to be fully shown. You would need to experiment with the styling options to achieve this. For example you may wish to hide the labels and tick marks, or go for a transparent font colour, to avoid having any superflous tick mark labels visible. Similarly you may need to choose a transparent axis line of a wider thickness, to achieve this extra space.

Hopefully this will point you in the right direction and give you some ideas in order to solve your issue.

If you need any further help please get in touch.

Thanks,

Kai.


#3

Hi Foobar,

I have noticed your duplicate post to this one which states you are using our iOS product. Apologies for my post above, I will leave this in place in case other (android users) face similar issues. In the meantime our iOS team will look into your other forum post.

Thanks,

Kai