Trying to get chart to take up full width of view


#1

I have a chart that I want to take up the full space of the view it is inside. I placed the y-axis in the reverse position on the left side so that the ticks will draw on top of the graph. The problem is that when I do this, the white space that normally was on the left side of the chart to make space for the y-axis is gone, but the graph view has just moved over to the left, leaving the right side of the view blank.

I’ve tried checking what the plot frame is, but don’t see access to it. If I change the color of the chart canvas, I can see that it runs all the way to the edge, but the plot area doesn’t.

Here are pictures for reference. Thanks.


#2

Hi Jgzhazarian,

Would it be possible for you to send a project demonstrating this issue throught to info@shinobicontrol.com with a reference to this forum post? I think that would make it easier to look into the problem for you!

Jan


#3

Thanks for the followup. I’ll see if I can find time to make a sample project with this, since right now it’s in a much larger project.


#4

I just sent an e-mail, but wanted to follow up here as well. It looks like this is reproducible in the LineChart demo project simply by adding these lines:

yAxis.axisPositionValue = @(0);

yAxis.axisPosition = SChartAxisPositionReverse;

What happens is that instead of just extending the graphing area to the left with the tick marks showing over it, it moves the graph over, without any resizing. This causes that right side to just be blank. I did a test by coloring the chart canvas purple and you can see that the blank space is indeed part of the chart canvas. Thanks for any further help.


#5

I can see the gap you are talking about. I have raised this issue with our development team and they will look into whether or not this is intentional, and if not, a fix will be released in a future release.

Thanks for giving us your feedback and we really appreciate you creating a cut down project for us to play with :grin:!

Jan


#6

After having a play with the tickGap property on my axis’ majorTickStyle object, it seems you can get rid of the gap by setting it to a large negative number like so:

yAxis.style.majorTickStyle.tickGap = @-50;

Jan