Trying to run Android sample PieSeriesActivity using shinobicharts-android-trial-1.0.0 (2)


Hi ,

I am trying to run sample app PieSeriesActivity  using shinobicharts-android-trail-1.0.0 ,but it giving error,application is stopped.Please help me .


Hi Rabindra,

I’m sorry, but there’s not really enough information here for me to give you a meaningful answer. Could you let us know what the error message is, and/or any other information about the problem, please? Also, is it just the PieSeriesActivity that is not working, or all of the samples?

Best regards,

Robin Sillem

Lead Developer




Thank you for your reply.The error message is “unfortunately PieSeriesActivity  has stopped”.One more sample code  ShinobiQuickstartActivity  also showing same  error when trying to run.The error I feel is ,the library project  packages are not taking during run time.I have tried by  adding two different ways your  library 1. by adding library jar to build path 2. adding library project as supporting project.But both ways giving same error.


Hi Rabindra,

Firstly, it looks like you’re using the v1.0 trial version - I’d recommend you download another trial version so you get our latest (v1.1.2) release which includes some extra features like BarSeries, Legends and Pan and Zoom notifications.

When you download a trial you’ll be sent an email (to the address you enter on the trial form) that has a licence.txt file attached. You’ll need to copy the contents of this file and then, in each sample you’re trying to run, paste it into the setLicenseKey method where it says <license_key_here>. Without  doing this you’ll get an InvalidLicenseException (this will show up in LogCat).

It’s worth noting that to add ShinobiCharts for Android you have to add it to Eclipse as a proper Android library project - just adding the .jar won’t work. The instructions in our User Guide, which is included in the download, walk you through importing the library correctly into Eclipse.

Let me know how you get on! If you’re still getting errors, first try cleaning all your projects in Eclipse and if you still have no joy let us know what error you’re getting (LogCat will provide a stack trace so you can see which particular error you’re getting).