Where can I download updated library version?


#1

Hello, 

Our company bought library January last year, Standar version. Now we know that Apple since february is requiring to submit apps with 64 Bit support, when I try to compile for those architectures, I get errors for Shinobi library. I wonder If there is an update for people who bought the library so we can submit our update Jan-february next year, and where can I get it?

Thx

Gustavo


#2

Greetings Program!

I believe the maintenance period is only valid for a year in which case you would need to renew it if you purchased it in January of 2013.

If your maintenance period hasn’t expired, you can get it through the Releases menu in the Customer Portal.

Wg


#3

We also have the same impending problem with 64 bit support.  I downloaded the trial version of 2.7.x for use with Xamarin but it still requires references to the monotouch assemblies, when this needs to be Xamarin.iOS now.

Any news on when the controls will be updated?

Thanks!


#4

Hi Dorian,

We are currently in the process of updating our bindings to support Xamarin’s Unified API.

We will update this forum post once a release containing the updated bindings are available.

Let me know if you have any questions.

Kind regards,
Andrew Polkinghorn


#5

Hi Andrew,

Do you have an update on the support for Xamarin’s Unified API? When will we get the release?

Regards,

Mohib


#6

wizgod

Greetings Program!

I believe the maintenance period is only valid for a year in which case you would need to renew it if you purchased it in January of 2013.

If your maintenance period hasn’t expired, you can get it through the Releases menu in the Customer Portal.

Wg

Hello,

So what shall I do in case the maintence period expired, can I get the ShinobiCare only as I already payed 400 US for the license, or another license is needed. ?

Gustavo.


#7

Hi Andrew,

Any more news on when you will be releasing an update that targets Xamarin’s Unified API?


#8

Any more new on when you will be releasing an update that targets Xamarin’s Unified API?


#9

Hello everyone,

We’ve just released our Unified API compatable Xamarin bindings - existing customers will be able to download them from the customer portal:

  • ShinobiCharts: 2.7.3.1
  • ShinobiGrids: 2.7.2.1
  • ShinobiEssentials: 2.7.1.1
  • ShinobiGauges: 2.7.1.1

If you have any issues, please get in contact with us either here or via email to info@shinobicontrols.com

Thanks - Jan


#10

Hi Jan,

when can we download the new releases? Currently they’re not yet available in the customer portal.


#11

Hi  any news about this?

have to deploy a new project but can’t until I update the Shinobi controls to latest with Xamarin unified api. If there where prbs found at least keep us in the loop so we know when we can expect the release.


#12

Hi Guys,

The release should now be available from the customer portal. We had a little bit of trouble with our release earlier this week so we decided to pull it until the issue had been resolved. If you have any trouble at all with the 64 bit compatable versions please send us an email to info@shinobicontrols.com and we’ll do our best to help!

We’re sorry for the inconvinience.

Thanks,
Jan


#13

I am sorry I don’t see any Xamarin binding in any of the 2.7.3 releases.  I downloaded each of the iOS premium charts for 2.7.3 and found no bindings.


#14

Hi hhodgert,

I’ve just had a look by downloading 2.7.3 from the support portal and found the bindings inside the Xamarin/lib folder.

If you still can’t find them, please get back in touch.

Sam


#15

Sam, you are correct I was just not looking at it the right way. Thanks,


#16

Anyone else seeing any weirdness in 64 bits? (My vertical annotations don’t appear on a 64 bit target like the iPhone 6, though the same code renders fine on a 32 bit iPhone 5).


#17

I just downloaded the latest versions and I am still getting the following error on a SDataGridCell subclass.

CS0012: The type MonoTouch.UIKit.UIView' is defined in an assembly that is not referenced. Consider adding a reference to assemblymonotouch, Version=0.0.0.0, Culture=neutral, PublicKeyToken=84e04ff9cfb79065’ (CS0012)

It says my ShinobiGrids version is 2.7.2.2.  Is there something else that needs to be done to get it work with a Unified project in Xamarin?


#18

Hi canderson,

Could I just check you’re using the latest version of grids ( 2.7.2.1 ) as this was the version that added support for Xamarin’s Unified API? You should be able to verify this by doing [ShinobiGrids getInfo] and logging this to the console. If not, could you download that version from our relase portal and give it another go?

Kind regards,

Sam